Bem-vindo à Comunidade UBNT

Perda de Pacotes (Muitas)

Olá,
Estou enfrentando problemas com uma rede WiFi (veja na imagem a topologia - as configurações são basicas - o local não é grande, todo aberto, é um bar), o raio não chega a 30 metros, o AP não está no centro, está em uma das laterais com visada para todo o resto da area.

Está havendo muitas perdas de pacotes o que tem ocosionado erros de time out na aplicação que roda nos mobile e que acessam o Servidor, pensei que pudesse ser algum equipamento com defeito, então eu fiz a troca de todos os equipamentos Unifi do Cenario 1 pelos do Cenario 2, ouve uma pequena melhora, não deu mais time out, mas tem ocorrido demora na resposta.

Estou usando o App WiFiman Android pra monitorar pois não sei exatamente onde fazer esse monitoramento na controladora.

Se alguem puder me dar dicas fico grato de como monitorar na controladora onde é o problema, se nos equipamentos Unifi ou no Servidor - já monitores com Ping em todos os equipamentos e ocorre perdas em todos.


Comentários

  • Samuel, eu estou usando o WiFiman porque eu não sei onde ver as informações de perdas de pacotes que preciso na Controladora!!

    Agraceço o retorno, mas na narrativa acima digo que tenho perdas e preciso identificar onde estão essas perdas pra procurar corrigir o problema.

    Na controladora tem essas informações, tem alguma rotina que faz o ping e me de detalhes??
  • UI-SamuelUI-Samuel 1398 Pontos
    É só olhar para o gráfico de retransmissão no dashboard e/ou cruzar essa informação com uma captura de pacotes em L2. Se a porcentagem de retry estiver alta, então existe um problema. Já identificar a causa, se for RF, requer um survey com ferramentas adequadas...
  • R4V3RR4V3R 8536 Pontos
    Comece, por favor, explicando como você fez pra determinar/medir a "perda de pacotes" a que se refere, assim como fornecer outras informações vitais pra qualquer tipo de análise, tais quais:
    1) Qual a quantidade de dispositivos móveis que são usados pra acessar essa aplicação?
    2) Quais os modelos desses equipamentos, e principalmente que tipo de conectividade? Em qual banda, 2.4 ou 5Ghz?
    3) Já que é um bar, qual a densidade de pessoas no local(média por alto), em momentos de pico?
    4) Existem outros sistemas de rede sem fio ao redor, principalmente se são disponibilizados pra uso do público do bar?
  • R4V3R

    No inicio da colocação do problema, coloquei um diagrama e discorri sobre o problema e minha necessidade, identificar onde está causando a perda de pacotes.

    A estrutura que montei não é consumida nem por 5% da sua capacidade!!

    1) Qual a quantidade de dispositivos móveis que são usados pra acessar essa aplicação? 7 tablets / smartphones, somente para os garçons
    2) Quais os modelos desses equipamentos, e principalmente que tipo de conectividade? Em qual banda? 2.4 (5 tablets Samsung) e  5Ghz (2 smarthones)
    3) Já que é um bar, qual a densidade de pessoas no local(média por alto), em momentos de pico? 40 pessoas no maximo
    4) Existem outros sistemas de rede sem fio ao redor, principalmente se são disponibilizados pra uso do público do bar? Sim, tem um AP exclusivo para os clientes, alem de outros da vizinhança.

    Tenho no local um Servidor HP com processador Xeon com SO Windows Server

    Quando optei por usar Unifi, foi pelas capacidades e custos melhores, alem dos recursos de software, porem não estou conseguindo achar nada na controladora que realmente me ajude a localizar onde é o problema, estou tendo uma ideia usando o WiFiman
  • R4V3RR4V3R 8536 Pontos
    Por favor, explique como você fez pra determinar/medir a "perda de pacotes" a que se refere.
  • PING do WiFiman
  • R4V3RR4V3R 8536 Pontos
    Certo. Disposisitivos móveis conectados à uma rede sem fio responderão à pings se quiserem, e no tempo que quiserem. Dito isso, perda de pacotes do tipo ICMP é não apenas esperada como perfeitamente normal.. O funcionamento neste sentido não é igual numa rede cabeada por causa dos inúmeros mecanismos de economia de energia envolvidos.. Esse é o primeiro ponto..
    Segundo ponto, você pode simplesmente ter interferência no local, isso é fácil de verificar porque seus dispositivos em 2.4Ghz e 5Ghz teriam comportamento e resultados bem diferentes neste sentido
    Terceiro ponto pode ser a própria aplicação em si, que pode não ter sido desenvolvida ou bem adaptada para funcionamento através de uma rede sem fio, que além da latência maior, naturalmente inclui colisão e retransmissão de frames, algo que muito dificilmente ocorreria num meio contido(cabo).
    Resumo da história, tem inúmeros fatores a serem verificados, e pra fazer isso, todos tem que ser isolados em seus respectivos domínios de atuação. A rede sem fio em si, e os access points, mais especificamente, são apenas uma pequenina parte de toda essa equação. Boa sorte. ;)
  • Essa perda no ping não sei se impactaria no processo, o que ocorre é que as vezes o aplicativo ao solicitar informações ao servidor e também ao enviar tem ocorrido demoras na resposta e as vezes até time-out. Como é uma aplicação antiga, ainda usa XML na comunicação com o Web Service.
  • hbtihbti 0 Pontos
    Olá @alfeu-ido tive problemas similares com meus coletores aqui na empresa, fui resolvendo por partes. Primeiro tinha perca de pacotes sequenciais, perdia 6 pacotes e voltava, passava uns minutos, perdia novamente uma quantidade de pacotes e voltava, não sendo normal fui direto nos meus AP's, troquei os mesmos e a perca de pacotes sequenciais foi resolvida, coloquei APs mais robustos, perde pacotes sim, mas um a cada 5 minutos o que no ambiente de dispositivos móveis é perfeitamente normal, porém, mesmo resolvendo a questão da perca de pacotes e a rede estando estável ainda havia lentidão, time out, dessa vez eram tabelas mal organizadas no meu banco de dados Oracle, resolvido o problema do time out, ainda havia lentidão e dessa vez resolvi criando uma SSID que só trabalha em 5GHz pois meus coletores se perdiam, mesmo com a opção Prefer 5GHz nos APs unifi eles ainda insistiam em conectar na 2.4GHz. Até chegar no ponto ideal pra trabalhar foram alguns dias de dor de cabeça, inclusive atualizando os androids dos coletores, instalando aplicativos e por aí vai, muitas variáveis e nem sempre está apenas na rede.
  • Olá @hbti Se ver na imagem acima estava utlizando AP nanoHD + Switch-8-60 + USG, troquei tudo, ficou AP FlexHD que é um nanoHD em outro formato + Switch-8-60 + USG - os equipamentos são tablets Sansung que se conecetam somente em 2.4Ghz e celulares que se conectam a 5Ghz, troquei de lugar os equipamentos para um local mais ventilado, mesmo com a troca o problema ainda continua, com menos frequencia mas continua. Obrigado pelas informações, vou tentar isolar casa uma das situações e ver o que acontece.
Entre ou Registre-se para fazer um comentário.