Bem-vindo à Comunidade UBNT

Uplink - US-48 / US-48-500W via SFP

Pessoal, bom dia.

Tenho um ambiente composto por um Switch Unifi - US-48, fazendo a função de ToR e mais quatro Switches Unifi - US-48-500W, realizando a função de acesso, todos com uplink via portas SFP+ e SFP.
Todos os meus GBICs são Unifi SFP e ao conectar ao ToR nas portas SFP+, o Switch de acesso não sobe e a porta de uplink do ToR fica com status "Blocked", que em teoria seria um looping em meu ambiente, lembrando que o RSTP está ativo em todos os switches e como a rede é nova e mapeada, não encontramos nenhum looping.

Fiz o teste com os uplinks via Ethernet e funciona normal.

É importante comentar que via SFP aparece a mensagem de comunicação STUN através da 3478 UDP, esse mensagem tem ocorrido somente nestes casos. A controller está no Azure, inclusive com outros sites e estão em perfeito funcionamento.

Alguém com uma situação similar ou possa ajudar?

Comentários

  • UI-SamuelUI-Samuel 1175 Pontos
    O STP só coloca uma porta em estado "blocked" quando de fato foi detectado um circuito fechado entre switches, lembrando que isso pode acontecer mesmo sem ligações redundantes entre dois switches, por exemplo quando houver 3 ou mais switches. Se essa infraeatrutura é somente UniFi, seria útil compartilhar a tela da topologia (em Maps/Topology) para saber como estão as ligações entre os switches. 

    Por exemplo, se USW1 é agregação de outros dois USW2 e USW3 através de uplinks isolados entre eles, não há circuito fechado. Se por acaso USW2 e USW3 tiverem alguma ligação entre si, formou-se o loop. Nesse caso, para o STP bloquear esse link entre USW2 e USW3 em vez de um dos uplinks do USW1, será necessário diminuir a prioridade dele (USW1) para fazê-lo ser o raiz da topologia STP. 
    jmnsolucoes
  • Olá Samuel, boa tarde.

    Claro. Todas as ligações estão indo para o ToR. Note que as portas 51 e 52 SFP estão normais, porém a 49 SFP+ não subiu o USW. Coloquei o outro equipamentos na porta 47 apenas como validação, mas ele deve ir para porta 50 SFP+ do ToR.

  • UI-SamuelUI-Samuel 1175 Pontos
    OK, então sugiro avaliar duas hipóteses, uma relacionada ao STP e outra à negociação L2. 

    1) Altere para 4096 a prioridade STP do seu switch ToR e aguarde alguns minutos depois do provisionamento para a reconvergência do STP:

    > Devices
    > Selecionar o Switch
    > Config
    > Services
    > Spanning Tree
    > Priority = 4096 (não 32768)

    Qualquer que seja o resultado, você pode manter essa configuração mesmo depois dos testes que é uma boa prática em switches de agregação...

    2) As interfaces 51 e 52 do US-48 são SFP+ (10G) e as interfaces 49 e 50 são SFP (1G), então pode ser que você esteja com algum problema na negociação automática da velocidade do módulo SFP de um lado com o módulo SFP+ do outro lado. Vale a pena testar o resultado ao fixar a velocidade em 1G dos dois lados e/ou usar o porta SFP do outro switch downlink (em vez da SFP+). 
    jmnsolucoes
  • Samuel, boa noite.

    Ótimo. Fizemos o ajuste no priority como o sugerido. Estou anexando duas imagens, a primeira com a porta autonegotiation e a segunda como 1 Gbps FDX.


    Note que o status permanece "Blocked", caso jogue o para porta ethernet ele sobe normalmente.
  • UI-SamuelUI-Samuel 1175 Pontos
    Não tem como o STP bloquear a porta de um switch raiz, no seu caso o switch que teve a prioridade setada em 4096, assumindo que todos os outros estejam com o valor padrão 32768. No pior dos casos o STP poderia bloquear esse link, mas através da interface do outro switch, não desse, já que na operação do protocolo todas as interfaces do switch raíz são designadas. Além disso, o fato da outra interface funcionar normalmente, sugere algum problema relacionado ao módulo SFP. 

    Acho que vale a pena tentar isolar se o problema ocorre  sempre com esse mesmo módulo ou sempre nessa mesma interface...

    Observação: Um outro teste válido é verificar e desativar o recurso Wireless Uplink nas configurações gerais do site para assegurar que nenhum AP está interferindo nesse processo (embora eles não deveriam fazer isso). 
    jmnsolucoes
  • Corrigido. Realmente o problema foi o SFP. Fizemos a substituição e o problema foi solucionado.
    Muito obrigado.
    UI-Samuel
Entre ou Registre-se para fazer um comentário.