Bem-vindo à Comunidade UBNT

UDM Pro - UDM is having an issue booting

Boa noite, 

Hoje (31/08) após os incidentes (coincidência?) reportados pela Ubnt, tentei acessar meu UDMP e a controladora de rede estava com a mensagem de "setup", como se não tivesse configurada anteriormente. Tentei acessar localmente e a mensagem era a mesma. A controladora Protect estava ok, tanto remoto quanto localmente. Tentei acessar via SSH e não consegui, estava dando acesso negado. Troquei a senha do SSH e tentei acessar e novamente o mesmo erro de acesso negado.  

Minha rede está funcionando normalmente, é uma configuração com 4 APs nanoHD, 4 switches Unifi, 5 6 VLAN´s, 3 WLAN e tudo parece "perfeito", apesar de não conseguir acessar a controladora. 

Reinicializei o UDMP pelo browser (settings) mas mesmo assim não consegui acesso. Fui até o equipamento para efetuar um reboot pelo touch e me deparei com a mensagem: "UDM is having an issue booting - try to reboot or enter recovery mode udm.ui.com/recovery". Rebootei o equipamento e o erro persiste. Quando entro pelo browser, aparece a mensagem na controladora de rede, "getting ready". 

Após o rebooting, nem mesmo a controladora Protect é acessível pelo browser/app. 


O UDMP está com o firmware 1.9.3
A controladora Protect está com a versão 1.18.1
A controladora Network está com a versão 6.2.25

Último back-up que tenho (fora os diários internos do UDPM) é de 01/08/21.

Alguém já passou por isso? Alguma sugestão para resolução? 

Comentários

  • UI-Samuel disse:
    @UI-Samuel Bom dia, obrigado pelo retorno. No artigo ele conduz para 3 opções.

    1 - Reinicialização para padrões de fábrica
    2 - Checagem do sistema de arquivos
    3 - Atualização do firmware 

    Qual a melhor opção? 

    Apesar de ter back-up da controladora de rede e da controladora do protect, entendo que a opção 1 eu perderia todas as gravações das câmeras?
  • UI-SamuelUI-Samuel 1355 Pontos
    Não existe a melhor opção, existe aquela que vai recupera o seu equipamento, qualquer que seja. Você pode começar pela opção menos agressiva que seria apenas verificar o sistema de arquivos, até ter que resetar e/ou subir outro firmware por cima. 

    Observação: Em cenários onde a disponibilidade das imagens do Protect é um requisito, o equipamento mais indicado é o UNVR que possui 4 bandejas de HDs ou o UNVR-PRO que possui 7 bandejas, ambos com suporte a RAID1/5 para que sempre haja uma cópia sincronizada. 
  • @UI-Samuel ;

    Talvez eu não tenha me expressado da forma correta, mas minha dúvida é se eu precisar fazer um reset de fábrica, instalar a controladora Protect e voltar o back-up dela, eu consigo recuperar ou fazer com que ela enxergue (linkar) as imagens que foram gravadas anteriormente? 

    Entendo que o problema que está ocorrendo é no sistema do UDM que deve utilizar algum meio de armazenamento interno e não o HDD onde o Protect armazena as gravações. RAID1/5 protege contra falha em um ou mais discos, mas não contra corrupção no sistema de arquivos (ou meio de armazenamento) das controladoras. Correto?
  • UI-SamuelUI-Samuel 1355 Pontos
    As memórias/partições do sistema UniFi OS (flash) e do armazenamento NVR (HDD) são independentes, então o RAID 1/5 dos NVRs com múltiplas bandejas é suficiente para manter cópias dos dados em outro(s) disco(s). Em relação ao UDM-PRO que possui um único HD, o procedimento de recovery pode implicar na formatação do HD, caso haja algum problema relacionado ao disco. Se o problema não for no disco rígido, então você pode até removê-lo e colocá-lo em outro UDM-PRO que os dados estarão lá...
  • Boa tarde @UI-Samuel

    Após alguns dias sem conseguir acessar as controladoras no UDMP, consegui tirar um tempo para tentar resolver o problema. Primeiramente desliguei o UDMP e antes de religar, retirei o HD do Protect. Apesar de ser um HD novo (5 meses) e específico para NVR (WD série Purple de 4Tb), pensei que pudesse ser nele o problema, afinal discos mecânicos são bem suscetíveis a falha. Para minha surpresa, o UDMP subiu sem acusar erro e com tudo funcional (exceto o Protect, óbvio). 

    Acessei os alertas e me surpreendi com diversos alertas de falta de espaço em disco. 

    Voltei o HD do Protect e tudo funcionou, o problema era realmente na falta de espaço em disco da controladora. 

    Neste momento exclui alguns arquivos de back-ups diários que estavam configurados para uma retenção de 100 arquivos. Reconheço que não precisava de tantos dias assim, as algumas perguntas que gostaria da sua ajuda @UI-Samuel é:

    1 - o que pode estar consumindo tanto espaço em disco além dos back-ups diários? O arquivo tem um tamanho médio de 50Mb o que daria 5Gb / 6Gb com base nos 100 arquivos. Não teria como ocupar os 12Gb do armazenamento total. 

    2 - Existe alguma forma do UDMP enviar um e-mail de alerta ou notificação push em casos de armazenamento cheio? Apesar de estar nos alertas, eu fiquei 2/3 dias sem entrar na controladora para acompanhar. 

    3 - Agora fazendo o monitoramento, percebi que de ontem para hoje, o armazenamento foi "consumido" com 150Mb. Alguma sugestão do que pode estar acontecendo? 

  • UI-SamuelUI-Samuel 1355 Pontos
    As imagens do sistema Protect são armazenadas no disco se você tiver habilitado a detecção de movimento. Nesse caso, em relação às imagens, as novas imagens automaticamente passam a sobrescrever as imagens mais antigas (1). Além disso, histórico de clientes também ocupa espaço em disco. Recomendo a leitura do artigo (2) e, se necessário, o procedimento de prune para fazer uma limpeza do BD.

    (1) https://help.ui.com/hc/en-us/articles/360037340954-UniFi-Hard-drive-compatibility-and-management#monitoring-hdd-space

    (2) https://help.ui.com/hc/en-us/articles/204911424-UniFi-How-to-Remove-Prune-Older-Data-and-Adjust-Mongo-Database-Size#4.5
  • Entendido sobre as gravações @UI-Samuel. Mas neste caso as gravações estão acontecendo no HD e não no armazenamento interno de 13.1/12.2Gb (informado no alerta) que foi o erro informado pela controladora. Creio que alguma coisa esteja consumindo muito espaço. Vou fazer o prune e acompanhar, mas veja meu raciocínio abaixo.


    Ontem (as 11:02) após excluir os arquivos de back-up antigos verifiquei que o consumo estava em 2.7Gb dos 13.1Gb. Foi neste momento que rebootei o equipamento sem o HD do Protect. 



    Agora (14:38) o consumo está em 3.02Gb dos 13.1Gb.



    Em torno de 320Mb em 27hrs. Descontando o back-up de 52Mb que foi executado na madrugada, houve um consumo de 268Mb neste período. 


    @UI-Samuel consegue me orientar/ajudar o que posso verificar / ajustar para diminuir este consumo? Porque creio que da forma como está, em poucos dias irá acontecer o mesmo problema de falta de espaço. 

  • UI-SamuelUI-Samuel 1355 Pontos
    Você deve verificar o procedimento de prune do BD que comentei antes (1), já que seu problema está relacionado à partição da controladora UniFi Network. A causa pode ser quantidade excessiva de erros gerando logs, quantidade excessiva de dados históricos dos clientes, quantidade de backups automáticos, etc... Outra forma de limpar o BD é restaurar um novo backup apenas das configurações (settings-only), sem nenhum dado histórico (2). Em último caso, começar do zero com uma nova instalação para identificar se foi algo corrompido no seu BD que não pôde ser corrigido. 

    (1) https://help.ui.com/hc/en-us/articles/204911424-UniFi-How-to-Remove-Prune-Older-Data-and-Adjust-Mongo-Database-Size#4.5

    (2) UniFi Controller: Como Fazer o Backup e Restauração das Configurações?
  • UI-SamuelUI-Samuel 1355 Pontos
    Outro teste que você pode fazer para validar se o problema está relacionado à coleta de dados históricos, é diminuir o período de retenção para o mínimo realmente necessário ou até mesmo desabilitar esse recurso nas opções de retenção dos dados:

    > Settings
    > Maintenance
    > Statistics Data Retention
    Collect Historical Data


Entre ou Registre-se para fazer um comentário.