Bem-vindo à Comunidade UBNT

Problemas de roaming na rede visitantes (hotspot Unifi)

Boa noite a todos. Vou realizar um resumo do ambiente que estou enfrentando problemas.

Segue cenário:

Quantidade APS: 45

Modelos: UAP-AC-LITE, UAP-AC-LR, UAP-AC-PRO e UAP-AC-M-PRO.

Cloudkey: UCKGen2 (2.1.11)

Versão software Controller: 6.2.26

VLANS: 3

Todo ambiente está como manda as boas práticas: Ajuste de canais adjacentes, ajuste de potência entre outros ajustes finos. O tema do tópico diz: Problemas de roaming somente na rede visitantes. Reforçando que temos este problema somente na rede Visitantes. Neste caso utilizamos o hotspot da Unifi. Nas demais VLANS não temos problemas com roaming. Utilizamos VOIP e coletores sem nenhum problema de roaming, tudo funciona perfeitamente como deveria.

Vamos ao problema: Um dispositivo ao conectar-se na rede visitantes entra com um voucher e está navegando, sem novidades. O problema é quando este dispositivo faz roaming. A conexão com a internet é interrompida e o usuário é obrigado a dar um clique em cima da notificação: “Ação necessária rede visitante”. O usuário não precisa inserir novamente o voucher, porém é obrigado a ter está “ação” de autenticação em seu dispositivo. Tanto faz se é Android ou IOS. Parece ser uma “falha de comunicação” da controladora em informar as outras APS que aquele dispositivo já foi autenticado no hotspot.

Já realizamos upgrade de firmware para versão 5.x, downgrade de firmware para 4.x e nada. Um fato interessante é que se o usuário não efetuar roaming ele continuará navegando até o fim da vida do Voucher.

Foi realizado troubleshooting na rede e não conseguimos detectar nenhum problema entre a APs e controladora. A latência efetuando um ping (AP) com destino a controladora não passa de 2ms. Anteriormente o ambiente era de 20 APS com UCKG1 e não tínhamos este problema. Como foi realizado uma ampliação na empresa, automaticamente foram necessários mais APs. Com isso fomos obrigados a migrar o UCKG1 para UCKG2 seguindo a recomendação do fabricante considerando a quantidade de APS X usuários. Este problema começou após realizamos a migração para UCKG2. Alguém já teve algum problema parecido?

Agradeço atenção de todos. 




Comentários

  • UI-SamuelUI-Samuel 1396 Pontos
    editado junho 2021

    Não é esse o comportamento de roaming com portal nos APs UniFi, já que a reautorização é automática (via controladora) e esse processo deveria ser rápido/transparente. Esse comportamento que você descreve sugere que o tempo de roaming dos clientes entre os APs está acima do desejado (até 50ms), o que pode estar desencadeando uma nova associação com o outro AP em vez de uma reassociação "suave" (roaming), normalmente por causa de problemas no dimensionamento/projeto da rede Wi-Fi.

    Caso seu roteador não seja um UDM/USG, certifique-se de que a comunicação foi permitida manualmente, conforme explicado nos tópicos (1,2). 

    (1) http://bit.ly/UniFi-Guest
    (2) http://bit.ly/UniFi-Guest-MAC

    Também é recomendado refazer um survey no local para avaliar o tempo de roaming entre APs. Caso seja confirmado que esse tempo está acima do esperado (durante a transição), então escolher os canais menos ocupados e diminuir as potências dos APs, principalmente se estiverem em auto, seguindo as boas práticas explicadas nos artigos (3,4).

    (3) http://bit.ly/WiFi-Projeto
    (4) http://bit.ly/WiFi-Survey

    danielmagalhaes
  • danielmagalhaesdanielmagalhaes 0 Pontos
    editado junho 2021
    Boa tarde. Obrigado pela resposta. O problema só ocorre no SSID guest quando habilitado hotspot. Conforme descrição acima não temos problemas de  roaming nas demais VLANs nos mesmos APs. Já foi realizado ajustes de canais entre outros ajustes conforme já descrito. Este comportamento só está acontecendo após migração de UCKgen1 para UCKgen2. Grato 
  • UI-SamuelUI-Samuel 1396 Pontos
    Não faz muito sentido, visto que o CK2 é apenas um mini servidor que hospeda o mesmo software da controladora que poderia ser instalado em qualquer máquina, assim como o CK1 já fazia. Um teste para isolar o CK2 como causa seria temporariamente testar parte da rede com a controladora em outro host.

    O roaming entre APs ocorre sem intervenção da controladora nesse processo, mesmo que ela esteja offline, exceto se houver um portal. É mais provável que o roaming esteja com tempo acima do recomendado nesse caso, talvez por latência na rede cabeada até sua controladora, já que um SSID com guest requer verificação adicional do status da autorização. 

    Se você estiver usando uma versão diferente da controladora em relação aos dois CKs, verifique se existe alguma configuração habilitada por padrão na versão mais recente que está diferente da versão anterior, por exemplo o recurso "BSS Transition" que aplica um MinRSSI automático de -75 em todas as células. 
    danielmagalhaes
  • danielmagalhaesdanielmagalhaes 0 Pontos
    editado junho 2021
    Boa noite pessoal. Sobre o roaming na rede visitantes após um troubleshooting realizado em conjunto com o TI interno do cliente. Foi ajustado o parâmetro em Acess Control e resolveu o problema. Neste campo conforme ilustração foi adicionado o IP da controladora.

    Somente compartilhando com os colegas que o problema aparentemente foi resolvido.


Entre ou Registre-se para fazer um comentário.