Bem-vindo à Comunidade UBNT

Firewall Bloqueando

Tenho varias aplicações funcionando através de nat com ip externo publico, vem varias portas diferentes uma delas 80 HTTP, externamente todos acessam essa aplicação normal, mais internamente não quando eu coloco o endereço me redireciona para a pagina do USG.
Outra questão é tenho clientes acessando minha rede interna via VPN PPTP acessam minha rede interna normal, porém quando tento acessar alguma aplicação que esta configurada através de nat não funciona.

No meu ver é o firewall que esta bloqueando algo, gostaria de alguma ajuda sobre o assunto! 

Comentários

  • UI-Samuel disse:
    Já li tudo, porém ainda não achei a solução de minha rede interna acessar minha aplicação na porta 80, continua caindo na pagina do USG. 
  • UI-SamuelUI-Samuel 1175 Pontos
    Se a aplicação é local e está na sua rede interna, então basta acessá-la diretamente pelo IP local. Se quiser acessar pelo nome, basta adicionar um registro A em um servidor DNS nessa sua rede local e o problema está resolvido sem que um acesso local tenha que sair/passar pela conexão externa. Você está tentando usar uma solução externa para tratar um acesso local - isso não faz sentido...
  • UI-Samuel disse:
    Se a aplicação é local e está na sua rede interna, então basta acessá-la diretamente pelo IP local. Se quiser acessar pelo nome, basta adicionar um registro A em um servidor DNS nessa sua rede local e o problema está resolvido sem que um acesso local tenha que sair/passar pela conexão externa. Você está tentando usar uma solução externa para tratar um acesso local - isso não faz sentido...
    mesmo com entrada A no meu servidor DNS, ele continua abrindo a pagina do USG, como que se quando ele fosse acessar a pagina da aplicação o USG impede e redireciona. 
  • UI-SamuelUI-Samuel 1175 Pontos
    E por acaso você está distribuindo seu DNS local no DHCP da rede interna em vez de usar o IP do USG que por padrão faz um cache local usando os servidores externos da conexão WAN? Senão não vai funcionar mesmo...
  • UI-Samuel disse:
    E por acaso você está distribuindo seu DNS local no DHCP da rede interna em vez de usar o IP do USG que por padrão faz um cache local usando os servidores externos da conexão WAN? Senão não vai funcionar mesmo...
    sim, estou apontando para meu servidor de DNS interno, que ja tem uma entrada no DNS, olha:


  • UI-SamuelUI-Samuel 1175 Pontos
    Essa configuração está "errada"... você está apontando o seu DNS interno para ser utilizado para resoluções externas nas opções do seu link WAN, o que (provavelmente) só vai aumentar a latência das suas resoluções, já que seus clientes poderiam simplesmente disparar a requisição diretamente para o servidor interno sem antes passar pelo USG - que antes teria que disparar outra requisição para esse mesmo servidor interno. O ideal é setar o seu DNS interno nas configurações do seu serviço DHCP (na LAN) para que ele seja usado apenas internamente pela(s) LAN(s), inclusive assim você elimina o USG como intermediário desse processo, o que otimiza o desempenho e facilita o troubleshooting. 
  • UI-Samuel disse:
    Essa configuração está "errada"... você está apontando o seu DNS interno para ser utilizado para resoluções externas nas opções do seu link WAN, o que (provavelmente) só vai aumentar a latência das suas resoluções, já que seus clientes poderiam simplesmente disparar a requisição diretamente para o servidor interno sem antes passar pelo USG - que antes teria que disparar outra requisição para esse mesmo servidor interno. O ideal é setar o seu DNS interno nas configurações do seu serviço DHCP (na LAN) para que ele seja usado apenas internamente pela(s) LAN(s), inclusive assim você elimina o USG como intermediário desse processo, o que otimiza o desempenho e facilita o troubleshooting. 
    certo, fiz o passo todo que falo porém continua sem resolver dando erro, ai são pessoas que estão conectadas via VPN e como pode ver ja recebem meu IP do servidor DNS que tem a entrada.



  • Continuo sem solução :(
  • R4V3RR4V3R 8512 Pontos
    Continuo sem solução :(
    E, infelizmente, não terá solução enquanto você continuar fazendo as coisas de maneira errada, fora de qualquer padrão recomendado.
    Primeiro que você está entregando um servidor DNS adicional externo(8.8.8.8) que não conhece a entrada "fluig" que você quer utilizar. Quando algum cliente for usar este servidor como DNS(depende da arquiterura e funcionamento de cada sistema operacional), o nome não será resolvido, sua solução não irá funcionar.

    Segundo que vocẽ precisa se preocupar não apenas com o "nome curto", "fluig" neste caso, mas sim com o FQDN, " Fully Qualified Domain Name", que pode ou não resolver corretamente pra dispositivos remotos, isso depende de inúmeros fatores, incluindo a forma como o nome é utilizado. Ex:
    ping fluig é uma coisa
    ping fluig.corp.local ṕode ser outra coisa, dependendo do contexto e forma de uso.

    Em suma, seu problema não está com configurações específicas no USG ou na VPN, mas sim com questões mais genéricas relacionadas à serviços de resolução de nomes, roteamento, NAT, firewall, etc.
  • R4V3R disse:
    Continuo sem solução :(
    E, infelizmente, não terá solução enquanto você continuar fazendo as coisas de maneira errada, fora de qualquer padrão recomendado.
    Primeiro que você está entregando um servidor DNS adicional externo(8.8.8.8) que não conhece a entrada "fluig" que você quer utilizar. Quando algum cliente for usar este servidor como DNS(depende da arquiterura e funcionamento de cada sistema operacional), o nome não será resolvido, sua solução não irá funcionar.

    Segundo que vocẽ precisa se preocupar não apenas com o "nome curto", "fluig" neste caso, mas sim com o FQDN, " Fully Qualified Domain Name", que pode ou não resolver corretamente pra dispositivos remotos, isso depende de inúmeros fatores, incluindo a forma como o nome é utilizado. Ex:
    ping fluig é uma coisa
    ping fluig.corp.local ṕode ser outra coisa, dependendo do contexto e forma de uso.

    Em suma, seu problema não está com configurações específicas no USG ou na VPN, mas sim com questões mais genéricas relacionadas à serviços de resolução de nomes, roteamento, NAT, firewall, etc.
    você esta errado, pois minha aplicação funciona em um subdomínio do meu principal, ou senha eletrodataengenharia.com.br é meu dominio e o fluig.eletrodataengenharia.com.br é meu subdomínio, e funciona sim pois ele é divulgado na internet, se voce for tentar acessar ai voce vai conseguir, outra criei a mesma entrada no meu FQDN com o mesmo nome, e funciona internamente, como eu disse, porém se um usuário externo entrar no link fluig.eletrodataengenharia.com.br, ele vai acessar mais se ele conectar a VPN para ter acesso a rede interna e tentar acessar o mesmo link não vai funcionar. Ele sera redirecionado para essa pagina do USG.
Entre ou Registre-se para fazer um comentário.