Bem-vindo à Comunidade UBNT

Solução: Atualização de APs UniFi com Firmwares Antigos

2»

Comentários

  • R4V3RR4V3R 8494 Pontos
    Use a 3.2.12 primeiro.. https://dl.ubnt.com/unifi/firmware/BZ2/3.2.12.6385/BZ.ar7240.v3.2.12.2920.150531.1645.bin
    Se não funcionar, você vai ter que procurar na internet por versões ainda mais antigas, pois já não estão mais disponíveis oficialmente para download.
    Além disso, sua única opção é pedir estes firmwares anteriores explicando a situação(em ingles) na comunidade global ou por email para support@ubnt.com
  • UI-SamuelUI-Samuel 1016 Pontos
    @RafaelAzevedo 

    Conversei com a engenharia sobre seu caso (que é bastante atípico) e vou compartilhar com você o arquivo do firmware 2.4.9 e do firmware 3.0.0 para que tente fazer a atualização local via SCP, já que não existe um um link público para utilizar com o comando "upgrade". Depois dessa atualização intermediária, você deve conseguir atualizar para uma versão 3.7.X e seguir a sequência de atualizações sugeridas neste tópico. 

    PROCEDIMENTO:

    > Fazer a atualização localmente via SCP, conforme explicado no artigo abaixo. 
    https://help.ubnt.com/hc/en-us/articles/204910064-UniFi-Changing-the-Firmware-of-a-UniFi-Device

    > Subir o firmware que vou te enviar em /tmp/fwupdate.bin (via SCP)
    > Depois de subir o arquivo do firmware, execute o comando:

    nohup syswrapper.sh upgrade &

    > A primeira atualização para o firmware 2.4.9, depois para o firmware 3.0.0.
    > Feito isso, você deve conseguir atualizar para a versão 3.7.X

    Envie um e-mail para mim que te envio os arquivos dos firmwares antigos, ok?
    samuel.brito@ubnt.com

    Observação: A engenharia reportou um caso recente de tentativa de atualização de um UAP-Outdoor com firmware 2.2 em que sequer foi possível atualizar para a versão 2.4.9 porque as mensagens de erro de CRC eram ocasionadas por um problema físico na flash do UAP. Se for esse o seu caso, então você tem um problema de hardware e não conseguirá atualizar para a versão 2.4.9.

  • RafaelAzevedoRafaelAzevedo 0 Pontos
    editado maio 2019
    @RafaelAzevedo 

    Conversei com a engenharia sobre seu caso (que é bastante atípico) e vou compartilhar com você o arquivo do firmware 2.4.9 e do firmware 3.0.0 para que tente fazer a atualização local via SCP, já que não existe um um link público para utilizar com o comando "upgrade". Depois dessa atualização intermediária, você deve conseguir atualizar para uma versão 3.7.X e seguir a sequência de atualizações sugeridas neste tópico. 

    PROCEDIMENTO:

    > Fazer a atualização localmente via SCP, conforme explicado no artigo abaixo. 
    https://help.ubnt.com/hc/en-us/articles/204910064-UniFi-Changing-the-Firmware-of-a-UniFi-Device

    > Subir o firmware que vou te enviar em /tmp/fwupdate.bin (via SCP)
    > Depois de subir o arquivo do firmware, execute o comando:

    nohup syswrapper.sh upgrade &

    > A primeira atualização para o firmware 2.4.9, depois para o firmware 3.0.0.
    > Feito isso, você deve conseguir atualizar para a versão 3.7.X

    Envie um e-mail para mim que te envio os arquivos dos firmwares antigos, ok?
    samuel.brito@ubnt.com

    Observação: A engenharia reportou um caso recente de tentativa de atualização de um UAP-Outdoor com firmware 2.2 em que sequer foi possível atualizar para a versão 2.4.9 porque as mensagens de erro de CRC eram ocasionadas por um problema físico na flash do UAP. Se for esse o seu caso, então você tem um problema de hardware e não conseguirá atualizar para a versão 2.4.9.

    @UBNT-Samuel  
     Ok, enviado.

  • UI-SamuelUI-Samuel 1016 Pontos
    editado maio 2019
    Recebido e retornado com os firmwares...
  • Recebido e retornado com os firmwares...
    Bom dia @UBNT-Samuel,
    Com os arquivos que me enviou, apresentou e mesma mensagem "U-Boot environment CRC is invalid!
    Unable to load U-Boot environment.", pode ser realmente algum problema de hardware.
    Obrigado pela atenção.
  • UI-SamuelUI-Samuel 1016 Pontos
    Agradeço pelo feedback. 
    Nesse caso realmente existe um problema no seu hardware (flash) que impede as atualizações. 
  • Boa tarde. 
    Samuel, 
    Fiz o procedimento de atualização via SSH para atualizar o AP Outdoor 5 (v. 2.3.6.1595) para (v. 3.7.58). 
    Baixa o download e inicia atualização, mas o AP só fica piscando os leds em laranja e não finaliza a atualização (já mais mais de 1h).
    O Putty já até ficou inativo.


  • UI-SamuelUI-Samuel 1016 Pontos
    Tente atualizar para a versão 3.0 que te enviei por e-mail. Se funcionar, você segue com o procedimento de atualização gradativa descrito nesse tópico. Caso contrário, seu AP tem um problema na memória flash e não será possível fazer a atualização.
  • edersonborgesedersonborges 2 Pontos
    editado outubro 2019
    Necessito atualizar Ap's UAP para a nova versão firmware, mas não encontro as versões antigas para atualização gradativa. Onde posso encontrar? Se algum possuir e puder me encaminhar via e-mail: edersonborges.oliveira@escola.pr.gov.br

    Versão atual:
    3.2.6.2799


  • UI-SamuelUI-Samuel 1016 Pontos
    https://ui.com/download/unifi
    (clicar em See Past Firmware)
  • Olá Pessoal

    irei entra no mesmo caminho, usar o SSH para atualizar o firware, pois estva usando o controller 4.7.5  e passei usar o controller 5.12.22  e um dos Unif AP-RL  está apresentando erro " Adoção Falhou Atualização necessaria" Versão 3.2.12.29.20

    O problema que quando acesso via SSH o Unifi  não sei qual usuario e senha para ter acesso, tentei ubnt  e não deu certo.
    qual seria o usuario para usar via SSH?
  • anarosaanarosa 0 Pontos
    Boa tarde!
    Estou com esse problema também, porém ao tentar acessar por SSH da access denied, como faço para conseguir o acesso SSH para atualizar gradativamente?


  • anarosaanarosa 0 Pontos
    anarosa disse:
    Boa tarde!
    Estou com esse problema também, porém ao tentar acessar por SSH da access denied, como faço para conseguir o acesso SSH para atualizar gradativamente?


    Peço que desconsiderem, não tinha visto a segunda pagina, estava tentando acessar o SSH pelo usuário e senha do "site" do controler por isso não estava indo. Obrigada
  • fredfabetfredfabet 0 Pontos
    UI-Samuel said:
    O firmware dos seus UAP legados é muito antigo, por isso será necessário fazer uma atualização gradativa com as seguintes versões intermediárias até chegar na atual versão 4.0.15, já que a partir da versão 5.10 a controladora UniFi requer pelo menos o firmware 4.0.9 nos APs:

    3.2.6 > 3.7.58 > 3.9.54 > 4.0.15

    Sugiro acessá-los via SSH e utilizar o comando "upgrade" seguido do link do firmware para fazer a atualização intermediária. Todos os links disponíveis na página de downloads da Ubiquiti são seguros (https), mas seu firmware é muito antigo, por isso será necessário trocar o HTTPS por HTTP na primeira atualização.


    Olá, Samuel! 

    Consegui atualizar da versão 3.2.1 para a 3.7.58, porém, não encontro o link para as próximas versões. 
    Onde eu consigo? 

    Meu AP é:

    M/N: Unifi AP
    FCC ID: SWX-UAP
    IC: 6545A-UAP

  • ThiemannThiemann 304 Pontos
    Olá, preciso da versão 3.1.6 pois o UAP ainda está na versão 2.x, não consegui atualizar direto para a 3.7.58 que é a mais antiga disponível no site..
  • UI-SamuelUI-Samuel 1016 Pontos
    @Thiemann A atualização deveria ter funcionado, o que indica que o AP é muito antigo e deve ter algum problema no seu hardware (flash) que impede as atualizações. De qualquer forma, me mande um e-mail (samuel.brito@ui.com) informando o modelo exato do seu AP que te envio o firmware 3.0 para você testar. 
  • ThiemannThiemann 304 Pontos
    UI-Samuel disse:
    @Thiemann A atualização deveria ter funcionado, o que indica que o AP é muito antigo e deve ter algum problema no seu hardware (flash) que impede as atualizações. De qualquer forma, me mande um e-mail (samuel.brito@ui.com) informando o modelo exato do seu AP que te envio o firmware 3.0 para você testar. 

    E-mail enviado, obrigado pela atenção por enquanto.
    UI-Samuel
Entre ou Registre-se para fazer um comentário.