Bem-vindo à Comunidade UBNT

Problemas Unifi AP - Conexões simultaneas

Olá amigos,

 

Continuo com problemas nos Unifi's AP, postei um tópico anteriormente, porém ficou faltando algumas informações e resolvi criar um novo topíco.

 

É o seguinte...

 

Tenho uma rede educacional com 9 Unifi's, distribuidos em 3 andares, cada um dos Unifi's recebem em média 40 conexões simultaneas.

 

O problema: Quando temos de 30 à 40 tablets conectados simultaneamente, o Unifi trava e não navega mais, sendo necessário reinicia-lo, e como é sala de aula o tempo para as atividades é limitado.

 

(Segue imagem da rede atual).

 

Mapa atual EMI.png

 

Destrinchando:

 

Do 1A para o 1B, são aproximadamente 15 metros de distância, do 1B para o 1C são aproximadamente 25 metros de distância. Esta medida se repete nos demais andares.

 

Pensando que o problemas podesse ser sobrecarga nos Unifi's, coloquei mais 1 Unifi no corredor, em frente as salas do 1A e 1B, para destribuir as cargas entre eles, porém o resultado foi o mesmo, quando todos se conectaram, ambos os Unifi's AP travaram.

 

Vejam o que falei no print à seguir. (Obs.: Neste print posicionei os Unifis para melhorar a visualização das janelas).

 

Usuários EMI2.png

 

Todos os Unifi's estão destribuídos entre os canais 1-6-11, e todos com a potência (Tx Power) low.

 

Utilizo um servidor Mikrotik (Routerboard 450G), com ampla faixa de IP's (DHC), restrições MAC/IP e  Load Balance (troca de link's automático, contra quedas de internet repentinas.)

 

Temos um link dedicado de 5MB + um link padrão de 35MB. (estáveis).

 

Obs.: No 3°Andar, salas 3A, 3B e 3C, esse problema não acontece, pois os números de dispositivos que necessitam se conectar aos Unifi's não passa de 5. Motivo pelo qual penso em sobrecarga.

 

Dúvidas:

 

Como posso ter certeza onde está o problema?

Se o problema for sobrecarga nos Unifi's como posso contornar esse problema?

 

 

 

 

Comentários

  • R4V3RR4V3R 8484 Pontos

    Olá @JonathanSantos , para um ambiente educacional, eu diria que 35 usuários/rádio já está no limite, mas para afirmar isso com certeza, depende do que os seus usuários estão fazendo. Se o tráfego nestes APs for intenso eles podem estar sobrecarregados, mesmo estando bem abaixo de sua capacidade máxima teórica. Qual o pico de usuários que você já registrou em um dado momento no total, e por AP?

    Links de internet você mencionou que tem um dedicado de 5Mb e um "padrão" de 35. Pela velocidade assumo que seja VDSL GVT, então pergunto: Ambos estão em uso simultaneamente, digo você está distribuindo a banda entre os dois, ou usa um apenas para backup? Pergunto isso pois:

    Um link VDSL da GVT dificilmente daria conta dessa gente toda. Eu não recomendaria utilizar com mais de 100 pessoas conectadas ao mesmo tempo, se fosse NET, não mais de 150.

    Já o link dedicado de 5Mb eu consideraria com velocidade abaixo do necessário para atender à demanda, eu recomendaria no mínimo 10, mas isso, claro, depende dos controles que você tem implantados, se a banda for bem gerenciada e as coisas bem amarradas, daria pra ser virar com 5Mb, mas ele ficaria trabalhando basicamente o tempo todo no talo.

  • Olá R4V3R,

     

    A média toral é de 180 usuários, porém distribuidos em 9 AP's. O número máximo de conexões simultanês em 1 unico Unifi AP chega a 40 em horários de pico, porém os outros 8 Unifi's estarão com 25~30 conectados.

     

    Utilizo o link de 5MB dedicado como principal e o 35MB VDSL GVT como backup automático. Tentei utilizar Hotspot no nosso servidor para gerenciar a banda, porém não deu certo, por se tratar de alunos acessando, sempre que é necessário uma autenticação de Login e Senha, gerá problemas!

     

    Outro ponto é que em horários de aula, a utilização desses equipamentos é para pequenas atividades, que normalmente não exigem muita banda, como responder questões Online, ou pesquisas, porém sempre tem aquele aluno que foge da aula e busca vídeos no youtube. Em ocasiões mais precisas, durante a aula é necessário o download de cadernos digitais que exigem mais banda.

     

    Porém, esse problema esta acontecendo em ambas os tipos de atividades, as menos exigentes de banda e as mais exigentes.

     

    Hoje 11/10/2014, realizei um pequeno teste, chegando a conectar 73 dispositivos no AP 1A (mostrado no esquema acima), desconectei os rádios mais proxímos, e mesmo após estas conexões o AP não travou.

     

    Obs.: Apenas conectei ao AP, não tentei sobrecarregar a banda para um segundo teste.

     

     

  • R4V3RR4V3R 8484 Pontos

    Tá bem estranho isso, como você está usando uma controladora ainda da geração 2(se não for a 2.4.6, recomendo atualizar o mais breve possível), você não tem acesso à aba de performance dos APs, que está disponível na versão 3 em diante, isso pode ajudar a identificar retransmissão de pacotes, interferencia, sobrecarga do espectro e coisas assim.

    Não existe neste local nenhuma outra rede wifi, digo, outros APs concorrendo nos mesmos canais, ou outras fontes de interferência como telefones sem fio, equipamentos bluetooth, fornos de microondas e etc?

    Realmente com 40 usuários não deveria apresentar problemas, principalmente dessa natureza de travar as conexões e não liberar até que o AP seja reiniciado, adianto que isso não é comum. Pra ter mais informações você vai ter que logar no AP em questão via SSH e ficar observando ele durante horários de pico, principalmente o log do sistema que fica em /var/log/messages

     

    Olha as imagens que capturei neste exato momento, sendo a primeira um UAP-PRO rodando em uma controladora 3.2.1 e a segunda são 5 UAPs normais na versão 2.4.6, todos instalados no mesmo local, um em cada uma das salas de aula, 6 no total aonde giram cerca de 300 alunos simultaneamente durante os fins de semana.

    uap-pro.PNG

     

    uap.PNG

     

    210 usuários conectados no total, e eles usam plataformas online de ensino, é uma escola de pos graduação. E isso que estão pendurados em um link net de 100Mb, bem chumbrega, não por recomendação minha mas por que ainda não definiram de qual operadora vão contratar o link dedicado.

    Outra coisa que se pode notar é que o balanceamento passivo no UAP-PRO entre 2G e 5G é perfeito, acho que sou o único nesse fórum que tem essa sorte pq normalmente os gringos reclamam pra caramba, dizendo que não há balanceamento, e na verdade não existe um balanceamento ativo mesmo, que seria o recurso band steering que está em testes ainda.

  • Olá R4V3R, muito obrigado pelo interesse em nosso problema.

     

    Realmente o problema é bem estranho, tínhamos 4 suposições do que estaria causando os problemas:

     

    1. Estrangulamento da banda, por se tratar de 2 links de baixa velocidade, referentes a nossa quantidade de usuários.

    2. Controladora 3.2.1

    3. Balanceamento de link's configurados no Mikrotik.

    4. Interferência dos outros APs.

     

    Observações:

     

    1. Utilizávamos o link de 5MB dedicado como link principal, e o 35MB VDSL como backup, para identificarmos se era esse problema trocamos os papeis dos link's, tornando o GVT 35MB VDSL como principal e o outro backup, e tivemos um resultado melhor que os outros testes, os travamentos diminuíram, porém não pararam.

     

    2. Utilizávamos a Controladora 3.2.1 e retornamos para a versão 2.4.6 para analisar se o problema poderia ser isso, permanecemos nessa versão, acho que isto não causaria problemas.

     

    3. Temos regras configuradas no Mikrotik para troca de link automático, quando um dos link's "cai", o outro assume automaticamente, porém a interface de saída permanece a mesma, não sabendo como o unifi responde a esta troca de link's, resolvemos retirar estas regras e realizar testes apenas com um link, e os resultados foram os mesmos, continuando os travamentos.

     

    4. O único tópico que não realizamos testes seguros.

     

    Não temos AP's na região que possa exercer tanta interferência, a não ser os próprios Unifi's.

     

    Também farei monitoramentos nos gráficos do Mikrotik para acompanhar a utilização da banda, e postarei aqui posteriormente.

     

    Realizarei este teste SSH que você recomendou.

     

    Mais uma vez obrigado!

  • R4V3RR4V3R 8484 Pontos

    De nada, vale a pena notar que nas imagens que postei acima, houve um pico de 80 usuários em um único UAP-PRO, balanceamento entre as bandas perfeito, e no total houve mais de 250 usuários simultâneos contabilizando os 6 APs e tudo em ordem, usando link NET de 100Mb.

    banda.PNG

    Esse é o uso de banda para o fim de semana, sexta, sábado e domingo. E uma informação importante é que só é possível usar este link pois o modem está configurado como bridge, ligado diretamente à meu servidor que está om Ubuntu server instalado com regras básicas de firewall, proxy squid(que salva um bocado de banda eventualmente) e também com a controladora UniFi.

    Antigamente o modem NET que é um Arris(eca) estava configurado em modo de roteamento, e já abria o bico com 150 usuários simultâneos, mesmo com o proxy implantando, mudá-lo para bridge fez uma diferença forte neste caso.

  • R4VER,

     

    Segue print's dos gráficos no MIKROTIK em horários de pico, com 160~180 usuários conectados.

     

    Link 5MB dedicado: (no talo)

     

    Faixa no talo.png

     

    Link 35MB:

     

    32MB.png

     

    Este link de 35MB utilizamos como backup, pois é muito instável.

     

     

     

  • R4V3RR4V3R 8484 Pontos

    Bom, fica claro que o seu maior problema é link de internet. Um está completamente sobrecarregado e o outro você diz que é instável.

    Uma coisa que achei muito estranho é que a contagem de pacotes por segundo na primeira imagem está muito baixa. Na segunda imagem está de acordo, mais de 1K por segundo, o que é esperado.

    Como é que está configurado o link da GVT? O modem está como bridge? Qual o modelo de modem? E quando você diz instável, que dizer que ele é intermitente, funcionando pra algumas pessoas e pra outras não, ou simplesmente para de funcionar, cai o sinal VDSL e corta tudo?

  • R4V3R,

     

    O modelo do Modem é um Power BOX Sagemcom F@st 2764 Gv, suas configurações são padrões e travadas para modificações, ou seja, do jeito que o Modem vem configurado, ele peramenece, e está confiturado como DHCP.

     

    Quando falamos instável, é que o sinal "cai" totalmente.

     

    Atualmente estamos utilizando o link de 5MB como padrão, devido sua estabilidade.

  • R4V3RR4V3R 8484 Pontos

    JonathanSantos wrote:

    R4V3R,

     

    O modelo do Modem é um Power BOX Sagemcom F@st 2764 Gv, suas configurações são padrões e travadas para modificações, ou seja, do jeito que o Modem vem configurado, ele peramenece, e está confiturado como DHCP.

     

    Quando falamos instável, é que o sinal "cai" totalmente.

     

    Atualmente estamos utilizando o link de 5MB como padrão, devido sua estabilidade.


    Pois é, é dificil melhorar esta situação, este modem da GVT não chega a ser ruim, mas é completamente bloqueado, nem mudar o endereçamento IP do miserável não é possível, o que é uma coisa ridícula obviamente...

Entre ou Registre-se para fazer um comentário.